Dashboard inaccessible
Incident Report for Elastic Path
Resolved
Service has been resumed with our third-party provider and the dashboard is now accessible again.
Posted Jan 10, 2020 - 17:17 UTC
Investigating
We're investigating reports that users are unable to access the Moltin dashboard.
Posted Jan 10, 2020 - 16:17 UTC
This incident affected: EU (EU Commerce Manager).