Issues affecting dashboard login
Incident Report for Moltin
Resolved
This incident has been resolved.
Posted 11 months ago. Sep 04, 2018 - 11:10 UTC
Investigating
We are investigating reports that some users are having issues logging into the store admin dashboard.
Posted 11 months ago. Sep 04, 2018 - 10:14 UTC
This incident affected: Dashboard.